Pengenalan VLAN (Virtual LAN)

Pengertian Vlan adalah sebuah device yang berada pada suatu LAN, Atau dengtan kata lain berada pada satu broadcast domain. Sebuah broadcast domain


Pengertian Vlan

Pengertian Vlan adalah sebuah device yang berada pada suatu LAN, Atau dengtan kata lain berada pada satu broadcast domain. Sebuah broadcast domain mencakup semua device yang terhubung pada LAN yang dimana jika salah satu device mengirimkan frame broadcast maka semua device yang lain akan menerima copy frame tersebut.

Tanpa Vlan, sebuah switch akan menganggap semua interface (port) yang berada pada satu broadcast domain, dengan kata lain, semua komputer yang terhubung ke switch ke dalam satu broadcast domain dan beberapa interface yang lain ke dalam broadcast domain yang berbeda, sehingga tercipta multipe broadcast domian.

Masing masing broadcast domain yang dibuat switch inilah yang kita sebut dengan Virtual LAN (VLAN).


Acces Port

Sebuah port pada switch yang telah di konfigurasi agar satu VLAN tunggal saja boleh melewatinya dinamakan Access Port.


VLAN Trunking

Saat menggunakan beberapa VLAN pada network yang memiliki beberapa switch yang saling terhubung, maka switch-switch tersebut harus menerapkan VLAN trunking pada segmen yang menghubungkan switch dengan switch lainya.

VLAN trunking mengakibatkan switch menggunakan proses yang dinamakan VLAN tagging, dimana switch yang mengirimkan data ke switch lain menambahkan header pada frame sebelumnya dikirimkan via trunk.

Header tambahan ini berisi VLAN indentifier (VLAN ID) sehingga switch pengirim bisa mencantumkan VLAN ID dari frame yang dikirimkan dan switch penerima akan mengetahui frame yang diterima ditunjukan untuk VLAN yang mana.


Default VLAN

Default VLAN (VLAN 1 pada Cisco) merupakan Vlan bawaan dimana semua port pada switch merupakan anggota VLAN default. ini mengakibatkan semua port pada switch akan menerima broadcast domain yang sama dan fungsi dari switch dengan konfigurasi bawaan ini akan menjadi seperti switch biasa (unmanageable).

VLAN default memiliki semua fitur dari Vlan lainya kecuali hanya vlan default tidak dapat dirubah namanya dan juga Vlan default ini tidak dapat dihapus.


Keuntungan VLAN

Berikut ini keuntungan dari VLAN :

1.Desain jaringan lebih flexsible, karena pengelompokan user tidak selalu tergantung dengan posisi fisik dari jaringan.

2.Sisi keamanan yang lebih, karena kita bisa mengelompokan user sesuai dengan sensitifitas data.

3.Kinerja jaringan lebih baik, karena dengan memecah jaringan ke segmen segmen yang lebih kecil, akan mengurangi trafik yang tidak diperlukan.

4.Dengan memecah kedalam segment-segment yang lebih kecil akan mempermudah dalam proses monitoring kondisi jaringan.


InterVLAN Routing

Inter VLAN Routing adalah proses routing yang dijalankan oleh router yang bertujuan agar masing-masing komputer pada VLAN yang berbeda bisa saling berhubungan.  


VLAN di Cisco 

Membuat VLAN Baru 

Switch>en 

Switch#vlan database 

Switch(vlan)#vlan 10 name staff 

VLAN 10 added: 

        Name: staff 

Switch(vlan)#vlan 20 name boss 

VLAN 20 added: 

         Name: boss 


Melihat konfigurasi VLAN 



Mengaktifkan VLAN 20 pada Port 1 (Fa0/1)

Switch#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z. 
Switch(config)#interface fastEthernet 0/1 
Switch(config-if)#switchport access vlan 10 
Switch(config-if)#switchport mode a 
Switch(config-if)#switchport mode access

Mengaktifkan Trunk di port 2 (Fa0/2) 

Switch#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z. 
Switch(config)#interface fastEthernet 0/2 
Switch(config-if)#switchport mode trunk

Memberikan Alamat IP ke Interface VLAN

Switch#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z. 
Switch(config)#interface vlan 10 
%LINK-5-CHANGED: Interface Vlan10, changed state to up 
Switch(config-if)#ip address 10.55.1.254 255.255.255.0 

Melihat Konfigurasi Sistem 

Switch #sh run 

Building configuration... 

Current configuration : 1102 bytes 

version 12.1 no service timestamps log datetime msec

no service timestamps debug datetime msec 

no service password-encryption 

hostname Switch 

! ! 

spanning-tree mode pvst 

interface FastEthernet0/1 

    switchport access vlan 10 

    switchport mode access 

interface FastEthernet0/2 

 switchport mode tr


VLAN di Linux

Pertama-tama, pastikan modul 8021q telah di load di sistem 

lsmod | grep 8021q 

Rubah konfigurasi eth0 pada /etc/sysconfig/network-scripts/ifcfg-eth0 (semisal VLAN akan di letakan di eth0) menjadi seperti berikut 

DEVICE=eth0 
TYPE=Ethernet 
BOOTPROTO=none 
ONBOOT=yes 

Kemudian buat file konfigurasi eth0.10 (vlan10) pada direktori /etc/sysconfig/networkscripts/ dengan isi seperti berikut 

DEVICE=eth0.10 
ONBOOT=yes 
VLAN=yes 
HOTPLUG=no 
BOOTPROTO=none 
NETMASK=255.255.0.0 
IPADDR=10.10.xx.xx 
GATEWAY=10.10.xx.xx 
TYPE=Ethernet 

Kemudian buat file eth0.20 (vlan 20) dengan isi sebagai berikut 

DEVICE=eth0.20 
ONBOOT=yes 
VLAN=yes 
HOTPLUG=no 
BOOTPROTO=none 
NETMASK=255.255.0.0 
IPADDR=10.20.xx.xx 
TYPE=Ethernet 

Untuk menerapkan konfigurasi si sistem, jalankan ulang service network nya 

sudo /etc/init.d/network restart 

InterVLAN Routing di Linux 

Untuk mengaktifkan InterVLAN routing, pertama-tama aktifkan paket forward nya pada file /etc/sysctl.conf sehingga seperti berikut

net.ipv4.ip_forward = 1 

Selanjutnya, buat rules iptables yang berfungsi untuk meneruskan paket dari satu VLAN ke VLAN lainya dan sebaliknya 

-A FORWARD -i eth0.10 -o eth0.20 -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT 
-A FORWARD -i eth0.20 -o eth0.10 -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT


VLAN di Mikrotik Membuat VLAN di Mikrotik

[admin@MikroTik] > interface vlan add vlan-id=10 interface=ether1 name=VLAN-staff [admin@MikroTik] > interface vlan add vlan-id=20 interface=ether1 name=VLAN-boss 

Mengaktifkan VLAN 10 di Port Ether2

[admin@MikroTik] > interface bridge add name=bridge-vlan10 [admin@MikroTik] > interface bridge port add interface=VLAN-staff bridge=bridge-vlan10 
[admin@MikroTik] > interface bridge port add interface=ether2 bridge=bridge-vlan10 

VLAN Trunking di Mikrotik

Untuk membuat port trunk di Mikrotik, buat beberapa interface VLAN, dan interfaceinterface VLAN tersebut pasangkan ke interface ether 1 (misalnya) maka secara otomatis interface ether 1 akan menjadi trunk.

Melihat Konfigurasi VLAN di Sistem

[admin@MikroTik] > interface vlan print 
Flags: X - disabled, R - running, S - slave  
# NAME                                                                                                 MTU ARP 
VLAN-ID INTERFACE                                                                                     0 R 
VLAN-staff                                                                                     1500 enabled 
10 ether1 
 1 R VLAN-boss                                                                                         1500 enabled 
20 ether1 

Memberikan Alamat IP Pada interface VLAN 

[admin@MikroTik] > ip address add address=10.55.1.40 netmask=255.255.255.0 interface=VLAN-staff

Berikut Tutorial Membuat Vlan Menggunakan Cisco




Penutup

Sekian Penjelasan mengenai VLAN semoga bermanfaat 

COMMENTS

Nama

Apple,6,Artikel,126,ASUS Rog Zephyrus g14,1,Backlink,1,Bahasa Indonesia,1,Bulu Tangkis,1,Console,14,Cyberpunk 2077,1,Dlc 2,1,fotografi,3,Game,13,guest post,1,History,4,html,3,Jenis Laptop,1,Masa Depan,2,NFC,1,Pc,3,pes 2013,3,pes 2020,3,pes 2021,4,Rekomendasi,1,Samsung,2,SepakBola,2,smartphone,3,soal rpl,3,soal tkj,19,Soal TKJ Kelas XI,1,Soal TKJ Kelas XII,1,Software Android,7,Software Pc,30,Steam,1,Teknik Informatika,1,Template,6,Ti,2,Tips,5,Tutorial,1,Xiaomi,1,
ltr
item
TECH PEDIA 04: Pengenalan VLAN (Virtual LAN)
Pengenalan VLAN (Virtual LAN)
Pengertian Vlan adalah sebuah device yang berada pada suatu LAN, Atau dengtan kata lain berada pada satu broadcast domain. Sebuah broadcast domain
https://1.bp.blogspot.com/-WHTpgvDAMIM/X-0ymt6SjxI/AAAAAAAACiM/sXJAtskwj6c-EB4yCttgq-zsSgYvrxRSQCNcBGAsYHQ/w400-h291/pengenalan%2Bvlan.jpg
https://1.bp.blogspot.com/-WHTpgvDAMIM/X-0ymt6SjxI/AAAAAAAACiM/sXJAtskwj6c-EB4yCttgq-zsSgYvrxRSQCNcBGAsYHQ/s72-w400-c-h291/pengenalan%2Bvlan.jpg
TECH PEDIA 04
https://www.techpedia04.my.id/2020/12/pengenalan-vlan-virtual-lan.html
https://www.techpedia04.my.id/
https://www.techpedia04.my.id/
https://www.techpedia04.my.id/2020/12/pengenalan-vlan-virtual-lan.html
true
3352910743458521246
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy Table of Content